• Bez kategorii

    Mikrotik Netflix QoS

    Easy and fast QoS configuration for Mikrotik RouterOS allowing to mark traffic from Netflix. With this config you can manage all Netflix traffic – and if you need – you can cut it down or make it high priority 🙂

    To use this method you will need to have own HTTP server (with PHP) – but it’s simple.

    First thing that need to be done is cloning this script:

    git clone https://github.com/sledzik1984/mikrotik-address-lists

    This script feches information about Netflix AS’es and converts them to RouterOS Address-List.

    After installing this on our web server you have to make few changes on your Mikrotik:

    /system script add name=update-lists source={
    :log info "Address lists update started";
    /tool fetch url="http://your.web.server/lists.php\?id=aws&name=dst-amazonaws" dst-path=aws.txt;
    /tool fetch url="http://your.web.server/lists.php\?id=facebook" dst-path=fb.txt;
    /tool fetch url="http://your.web.server/lists.php\?id=google" dst-path=google.txt;
    /tool fetch url="http://your.web.server/lists.php\?id=bso" dst-path=bso.txt;
    /tool fetch url="http://your.web.server/lists.php\?id=netflix" dst-path=netflix.txt;
    /tool fetch url="http://your.web.server/lists.php\?id=proceau" dst-path=proceau.txt;
    /import file-name=aws.txt; /file remove aws.txt;
    /import file-name=fb.txt; /file remove fb.txt;
    /import file-name=google.txt; /file remove google.txt;
    /import file-name=bso.txt; /file remove bso.txt;
    /import file-name=netflix.txt; /file remove proceau.txt;
    /import file-name=proceau.txt; /file remove netflix.txt;
    :log info "Address lists updated";
    }





    Next thing to do is forcing Mikrotik to update those lists:

    /system scheduler
    add interval=1h name=update_address_lists on-event=update-bgp-lists policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon

    With that – Mikrotik will refresh lists each hour.

    Published by:
  • Bez kategorii

    Homemade bread of Grandma Barbara

    Ingredients for 3 breads baked in bread molds:

    • 200 g of rye flour
    • 1300 g of wheat flour
    • 3 level teaspoons of salt
    • 3 handfuls of lineseed
    • 3 handfuls of husked sunflower
    • 50 g yeast
    • 500 ml of warm milk
    • 1000 ml of warm water
    • 1 teaspoon sugar
    • Poppy seed

    Pour flours, seeds and salt to large bowl.




    Pour milk, water into second bowl. Add crumbled yeast. We have to wait until yeast are “alive” – wait 20 minutes.

    Pour liquid yeast to the dish with flours, thoroughly knead by hand. Cover with a cloth and leave in a warm place for 20 minutes (to rise).

    Put baking paper into bread molds. When dough we put into molds a wet hand – then less sticky. The surfaces of the dough aligns hand. We sprinkle with poppy seeds.

    Once again, we leave for a moment to rise.

    When you grow up to half molds Put in a cold oven. Oven set to work “top and bottom heater”, without convection, no fan oven, 200 degrees C.

    After 30 minutes turn off the top heat and reduce the temperature to 180 degrees C. Bake for another 30 minutes.

    Bread immediately after pulling out of the oven pull out of the molds and take off any paper.

    Published by:
  • Bez kategorii

    Novastar (LINSN) LED screen over fiberoptical cable

    Most of Led Screens available in Europe (and China of course) is driven by Novastar products. All data connections are made with typical CAT5e cables.
    We are limited to 100 meters of cable – just like in normal ethernet networks.

    Few weeks ago I’ve had job at which Novastar senders had to be away from the screen for more than 300 meters. Of course there is no chance to use CAT5 cable.

    Novastar sells fiber optical converters that can send LED screen signal for more than 300 meters – but I couldn’t get them in our warehouse soon enough.

    First thing that came to my head was using regular Gigabit Optical Media Converters with Novastar. We own many TPLink MC220L SFP media converters that we use making hotspots on events.

    TPLink MC220L SFP

    Schematic of connection:

    Novastar MCTRL660 ——- RJ45 —–> TP-Link —– 350 m Fiber —> TP-Link —- RJ45 —-> Led Screen

    Connection works! So you can use that (and propably any other Gigabit fiber to RJ45 mediaconverter).

     

    Published by:
  • Bez kategorii

    Testing USB Car Charger: SA-2211

    This year, my wife went on vacation alone with children. I’ve decided to equip her with mobile phone holder and GPS navigation software. This kit would not have any sense if I did not give it a permanent power source.
    Żona jechała w tym roku na wakacje sama z dziećmi. Postanowiłem wyposażyć ją w uchwyt do telefonu i soft do nawigacji. Zestaw ten nie miałby żadnego sensu gdybym nie zapewnić mu stałego źródła zasilania. So I bought the car charger with two USB outputs . I chose a product with the theoretical parameters:

    – Input Voltage: 12VDC
    – Output Voltage: 5VDC
    – Current: 2,1A per USB port!

    A decent piece of hardware , right?

    My wife went on vacations. Phone was dead after 100 km (60 miles).

    Jako, że posiadam malutki miernik USB – sprawdziłem realne parametry ładowarki USB SA-2211:
    SA-2211 USB Charger

    Zdjęcie to zrobiłem podczas próby naładowania mojego iPhone’a 5s od 10% z załączoną Automapą. Niestety tą ładowarką nie da się ładować telefonu jednocześnie z niego korzystając. W przypadku gdy prąd płynący przez ładowarkę zbliża się do 0,5A – napięcie na wyjściu spada poniżej normatywnych 5V.

    Po rozebraniu urządzenia okazuje się, że nie ma ono prawa nawet zbliżyć się do obiecywanych przez sprzedającego 2,1A na każdy port USB.

    SA-2211 2x2,1ASA-2211 Interior

     

     

     

     

     

    Pierwszy problem z obiecywanym przez firmę m-importer prądem 2,1A na port USB to to, że porty mają wspólne nogi. Nie możemy mówić o tym, że któryś port ma jakąś wydajność gdyż są połączone ze sobą równolegle. Dodatkowo – opis na urządzeniu sugeruje, że port górny ma wydajność 2,1A a dolny 1A. Widać to pięknie po lewej stronie naklejki przyklejonej poniżej portów USB. Opis na tej naklejce mówi również o wydajności prądowej 2000 mA.

    Gdy przyglądniemy się dokładniej wnętrzu tego urządzenia od razu widać, że nie należy ono do skomplikowanych. Ot 1 układzik, 2 kondensatory, cewka.

    Układzik zarządzający pracą całości to chińska przetworniczka DC-DC Buck. Po przetłumaczeniu sobie datasheetu scalaka wychodzą dokładnie wszystkie kłamstwa sprzedającego (a może producenta który oszukał sprzedającego?).

    Układ ten ma wydajność 0,8A. Nie 2,1A. Nie 4,2A (a o takiej wydajności pisze sprzedający z Allegro)

    Nie jest to pierwsza ładowarka którą kupuję na Allegro. Niestety za każdym razem wydajności podawane przez sprzedających są zawyżane do poziomów które są po prostu mało realne do osiągnięcia w urządzeniu rozmiarów wtyczki zapalniczki samochodowej.

     

    Published by:
Akceptuję
Śmietnik wykorzystuje pliki cookies. Korzystanie z witryny oznacza zgodę na ich zapis lub odczyt zgodnie z ustawieniami przeglądarki.