Mikrotik Netflix QoS

Comment

Bez kategorii

Easy and fast QoS configuration for Mikrotik RouterOS allowing to mark traffic from Netflix. With this config you can manage all Netflix traffic – and if you need – you can cut it down or make it high priority 🙂

To use this method you will need to have own HTTP server (with PHP) – but it’s simple.

First thing that need to be done is cloning this script:

git clone https://github.com/sledzik1984/mikrotik-address-lists

This script feches information about Netflix AS’es and converts them to RouterOS Address-List.

After installing this on our web server you have to make few changes on your Mikrotik:

/system script add name=update-lists source={
:log info "Address lists update started";
/tool fetch url="http://your.web.server/lists.php\?id=aws&name=dst-amazonaws" dst-path=aws.txt;
/tool fetch url="http://your.web.server/lists.php\?id=facebook" dst-path=fb.txt;
/tool fetch url="http://your.web.server/lists.php\?id=google" dst-path=google.txt;
/tool fetch url="http://your.web.server/lists.php\?id=bso" dst-path=bso.txt;
/tool fetch url="http://your.web.server/lists.php\?id=netflix" dst-path=netflix.txt;
/tool fetch url="http://your.web.server/lists.php\?id=proceau" dst-path=proceau.txt;
/import file-name=aws.txt; /file remove aws.txt;
/import file-name=fb.txt; /file remove fb.txt;
/import file-name=google.txt; /file remove google.txt;
/import file-name=bso.txt; /file remove bso.txt;
/import file-name=netflix.txt; /file remove proceau.txt;
/import file-name=proceau.txt; /file remove netflix.txt;
:log info "Address lists updated";
}





Next thing to do is forcing Mikrotik to update those lists:

/system scheduler
add interval=1h name=update_address_lists on-event=update-bgp-lists policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon

With that – Mikrotik will refresh lists each hour.

Leave a Reply

Your email address will not be published. Required fields are marked *

Akceptuję
Śmietnik wykorzystuje pliki cookies. Korzystanie z witryny oznacza zgodę na ich zapis lub odczyt zgodnie z ustawieniami przeglądarki.