Category Archives: Elektronika

Mikrotik Netflix QoS

Elektronika

Szybka konfiguracja QoS na RouterOS pozwalająca oznaczać ruch pochodzący z serwisu Netflix. Dzięki temu można nad tym ruchem zapanować, w razie potrzeby przyciąć go lub nadać mu wysoki priorytet 🙂

Metoda co prawda wymaga posiadania własnego serwera WWW (z PHP) ale jest dość prosta 🙂

Instalujemy na serwerze WWW skrypt:

git clone https://github.com/sledzik1984/mikrotik-address-lists

Skrypt pobiera z sieci informacje o AS’ach Netflixa i przetwarza je na Address-Listę której można użyć w RouterOS

Po instalacji powyższego skryptu musimy na naszym routerze stworzyć skrypt:

/system script add name=update-lists source={
:log info "Address lists update started";
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=aws&name=dst-amazonaws" dst-path=aws.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=facebook" dst-path=fb.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=google" dst-path=google.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=bso" dst-path=bso.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=netflix" dst-path=netflix.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=proceau" dst-path=proceau.txt;
/import file-name=aws.txt; /file remove aws.txt;
/import file-name=fb.txt; /file remove fb.txt;
/import file-name=google.txt; /file remove google.txt;
/import file-name=bso.txt; /file remove bso.txt;
/import file-name=netflix.txt; /file remove proceau.txt;
/import file-name=proceau.txt; /file remove netflix.txt;
:log info "Address lists updated";
}





Musimy zadbać również o aktualizację powyższych address-list

/system scheduler
add interval=1h name=update_address_lists on-event=update-bgp-lists policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon

RouterOS co godzinkę odświeży sobie address-listy i będziemy mogli ich użyć do znakowania pakietów w tablicy Mangle (i dalej w QoS)

Published by:

Test ładowarki USB SA-2211 2000 mA

Elektronika

Żona jechała w tym roku na wakacje sama z dziećmi. Postanowiłem wyposażyć ją w uchwyt do telefonu i soft do nawigacji. Zestaw ten nie miałby żadnego sensu gdybym nie zapewnić mu stałego źródła zasilania. Kupiłem więc również samochodową ładowarkę z dwoma wyjściami USB. Wybrałem sobie produkt o teoretycznych parametrach:

– napięcie zasilania 12V
– napięcie wyjściowe 5V
– prąd 2,1A na gniazdo USB

Dokładny opis ładowarki z Allegro:

Ładowarka USB SA-2211

Piękny produkt prawda? I cena jakaś taka niska 😉

Żona pojechała na wakacje. Telefon padł jej po 100 km. To pokazało realne możliwości tej „bestii”.

Jako, że posiadam malutki miernik USB – sprawdziłem realne parametry ładowarki USB SA-2211:
SA-2211 USB Charger

Zdjęcie to zrobiłem podczas próby naładowania mojego iPhone’a 5s od 10% z załączoną Automapą. Niestety tą ładowarką nie da się ładować telefonu jednocześnie z niego korzystając. W przypadku gdy prąd płynący przez ładowarkę zbliża się do 0,5A – napięcie na wyjściu spada poniżej normatywnych 5V.

Po rozebraniu urządzenia okazuje się, że nie ma ono prawa nawet zbliżyć się do obiecywanych przez sprzedającego 2,1A na każdy port USB.

SA-2211 2x2,1ASA-2211 Interior

 

 

 

 

 

Pierwszy problem z obiecywanym przez firmę m-importer prądem 2,1A na port USB to to, że porty mają wspólne nogi. Nie możemy mówić o tym, że któryś port ma jakąś wydajność gdyż są połączone ze sobą równolegle. Dodatkowo – opis na urządzeniu sugeruje, że port górny ma wydajność 2,1A a dolny 1A. Widać to pięknie po lewej stronie naklejki przyklejonej poniżej portów USB. Opis na tej naklejce mówi również o wydajności prądowej 2000 mA.

Gdy przyglądniemy się dokładniej wnętrzu tego urządzenia od razu widać, że nie należy ono do skomplikowanych. Ot 1 układzik, 2 kondensatory, cewka.

Układzik zarządzający pracą całości to chińska przetworniczka DC-DC Buck. Po przetłumaczeniu sobie datasheetu scalaka wychodzą dokładnie wszystkie kłamstwa sprzedającego (a może producenta który oszukał sprzedającego?).

Układ ten ma wydajność 0,8A. Nie 2,1A. Nie 4,2A (a o takiej wydajności pisze sprzedający z Allegro)

Nie jest to pierwsza ładowarka którą kupuję na Allegro. Niestety za każdym razem wydajności podawane przez sprzedających są zawyżane do poziomów które są po prostu mało realne do osiągnięcia w urządzeniu rozmiarów wtyczki zapalniczki samochodowej.

 

Published by:

Ekstendery HDMI po IP (LEKENG LKV373, HDMI-EX120, TF680, SIGNAL HD H3604 … )

Większość osób które kiedykolwiek miały do czynienia ze standardem HDMI doskonale wie, że jesteśmy bardzo mocno ograniczeniem długością kabla. Krótkie kable HDMI po prostu działają. Wszelkie teorie o kablach lepszych czy gorszych w przypadku kabli do 5m można raczej wrzucić do śmietnika. Sprawa mocno komplikuje się w przypadku kabli o długości powyżej 15 metrów. Z doświadczenia powiem, że kable > 15 m to raczej loteria. Dany kabel z jednym kompletem urządzeń będzie działał normalnie a z innym w ogóle. Dodatkowo kable HDMI są grube co utrudnia ich prowadzenie pod tynkiem czy w peszlach. Wg. zapewnień producentów rozwiązaniem powyższych problemów są konwertery HDMI na skrętkę UTP czy IP. Na rynku dostępne są konwertery zarówno topowych producentów sprzętu AV (np. Kramer) jak i sprzęt wyprodukowany przez małe chińskie rączki. Dziś skupimy się na raczej tańszym chińskim sprzęcie.

Continue reading

Published by:

DAB+ w Krakowie – pierwszy test…

Elektronika

31 grudnia 2014 z RTCN Chorągwica została uruchomiona testowa transmisja cyfrowego radia DAB+. Wrodzona ciekawość (i posiadanie odbiornika RTL-SDR) zmusiła mnie do próby odebrania tej transmicji…

Do obsługi cyfrowego radia postanowiłem użyć programu SDR-J. Program dostępny jest zarówno dla Windows jak i Linuxa (jednak z przypadku tego drugiego trzeba skompilować go samemu ze źródeł). Ja – wybrałem wersję dla Linuxa.

Kompilacja

Pobrane ze strony autora źródła należy oczywiście rozpakować

# tar -zxvf sdr-j-dabreceiver-0.97.tar.gz
# cd sdr-j-dabreceiver-0.97
sdr-j-dabreceiver-0.97#

Po zapoznaniu się z plikiem README stwierdziłem, że brakuje mi całkiem sporej ilości bibliotek wymaganych do kompilacji SDR-J. Aby udało nam się skompilować program musimy zainstalować brakujące biblioteki:

Continue reading

Published by:

Ładowarka BattMan II [Tłumaczenie + MODYFIKACJE]

Elektronika

Poniżej przedstawiam tłumaczenie dość długiego artykułu dotyczącego bardzo fajnej, kontrolowanej przez komputer PC ładowarki wszelkiej maści akumulatorów. Ja zainteresowałem się niąbattman2 z zupełnie innego powodu… Dzięki nie jestem w stanie ocenić stan zużycia akumulatora oraz jego jakość.

Projekt został przeze mnie dość mocno zmodyfikowany. Dodałem dwa mierniki panelowe – jeden wskazuje napięcie (wejściowe lub ładowania), drugi wskazuje prąd płynący przez akumulator.

Continue reading

Published by:

MUSTEK Powermust 600VA – funkcja Green

Akwarystyka Elektronika

Dostałem ostatnio UPS’a Mustek Powermust 600VA. Jak na moje potrzeby – w zupełności wystarczający. W końcu muszę zabezpieczyć nim tylko filtr kubełkowy do akwarium a ten ma niewiarygodnie wielki pobór mocy – całe 8W.

Niestety – firma Mustek nie wiadomo po co dołożyła do UPS’a funkcję Green. Czym ta funkcja się przejawia? Otóż jeżeli z jakichś powodów nagle stracimy zasilanie a do wyjścia UPS’a podłączone są odbiorniki których sumaryczna moc nie przekracza około  60 – 70 W to po dokładnie 5 minutach UPS odłączy nam wyjście. No i po zawodach…

Po cholerę mi UPS który niezależnie od tego jaki w nim jest akumulator jest w stanie podtrzymać urządzenia całe 5 minut?! Skreśla to użycie tego urządzenia do podtrzymywania filtrów akwariowych, pomp obiegu centralnego ogrzewania itd.

Na szczęście udało się ten kretyński ficzer wyłączyć. Aby tego dokonać potrzebować będziemy śrubokręta Philips (popularny krzyżak) – niestety ale nie może on być zbyt gruby i krótki. Dodatkowo musimy dysponować jeszcze lutownicą oraz odsysaczem do cyny.

Po wymontowaniu płyty głównej urządzenia musimy odnaleźć na niej zwykły przewlekany rezystor R15A (oznaczony również jak GRN). Jest mały ale wprawne oko i po kilku minutkach namierzycie rezystor.

Aby funkcję wyłączyć – rezystor oczywiście wylutowujemy. Ja osobiście wylutowałem 1 nóżkę i zaizolowałem ją taśmą. Niech sobie tam siedzi – a nóż kiedyś postanowię tą funkcję załączyć…

Bez tego rezystora – UPS będzie starał się podtrzymać napięcie tak długo aż nie braknie energii zgromadzonej w akumulatorach.. W moim przypadku – na wcale nie nowej żelówce 7,2 Ah – ponad godzinę.

Aktualizacja

Niestety – skreśliłem ten UPS z listy urządzeń które wspomagają funkcjonowanie mojego akwarium. Jak wiadomo tanie UPSy dają na wyjściu przebieg odbiegający znacznie od sinusoidy. Niestety w przypadku przebiegu z tego Musteka mój pompa mojego kubełka (Tetra EX700) kręciła się sporo wolniej – wydajność filtracji spadła zbytnio. Do podtrzymywania filtrów polecam więc UPSy dające na wyjściu pełną sinsusoidę – np. APC

Published by:
Akceptuję
Śmietnik wykorzystuje pliki cookies. Korzystanie z witryny oznacza zgodę na ich zapis lub odczyt zgodnie z ustawieniami przeglądarki.