Mikrotik Netflix QoS

Comment

Elektronika

Szybka konfiguracja QoS na RouterOS pozwalająca oznaczać ruch pochodzący z serwisu Netflix. Dzięki temu można nad tym ruchem zapanować, w razie potrzeby przyciąć go lub nadać mu wysoki priorytet 🙂

Metoda co prawda wymaga posiadania własnego serwera WWW (z PHP) ale jest dość prosta 🙂

Instalujemy na serwerze WWW skrypt:

git clone https://github.com/sledzik1984/mikrotik-address-lists

Skrypt pobiera z sieci informacje o AS’ach Netflixa i przetwarza je na Address-Listę której można użyć w RouterOS

Po instalacji powyższego skryptu musimy na naszym routerze stworzyć skrypt:

/system script add name=update-lists source={
:log info "Address lists update started";
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=aws&name=dst-amazonaws" dst-path=aws.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=facebook" dst-path=fb.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=google" dst-path=google.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=bso" dst-path=bso.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=netflix" dst-path=netflix.txt;
/tool fetch url="http://adres.twojego.serwera/lists.php\?id=proceau" dst-path=proceau.txt;
/import file-name=aws.txt; /file remove aws.txt;
/import file-name=fb.txt; /file remove fb.txt;
/import file-name=google.txt; /file remove google.txt;
/import file-name=bso.txt; /file remove bso.txt;
/import file-name=netflix.txt; /file remove proceau.txt;
/import file-name=proceau.txt; /file remove netflix.txt;
:log info "Address lists updated";
}





Musimy zadbać również o aktualizację powyższych address-list

/system scheduler
add interval=1h name=update_address_lists on-event=update-bgp-lists policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon

RouterOS co godzinkę odświeży sobie address-listy i będziemy mogli ich użyć do znakowania pakietów w tablicy Mangle (i dalej w QoS)

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Akceptuję
Śmietnik wykorzystuje pliki cookies. Korzystanie z witryny oznacza zgodę na ich zapis lub odczyt zgodnie z ustawieniami przeglądarki.